Solucionar error al recortar imágenes WordPress

Portada del diario

Acabo de encontrarme con un error al recortar imágenes en WordPress. Esto me ha pasado subo una imagen y WordPress me da la opción de recortar, por ejemplo para añadir un favicon o algo así. Pasa con cualquier imagen, y claro, esto es un problema importante.

El error que da es muy explícito: “Se ha producido un error recortando la imagen.”. Si tienes tu instalación en inglés saldrá: “There has been an error cropping your image.”

Error al recortar imagen

Pues bien, si esto te pasa en un hosting que hospedes tú en tu servidor, posiblemente no tengas instalado un módulo necesario de php. En este caso hablamos del php*-gd. Este módulo tiene que existir en la instalación del servidor web, o dará dicho error. Se encarga del procesamiento de imágenes, y es necesario para recortes, por ejemplo.

Cuando pongo el asterisco es porque dependerá de tu versión de php. En este momento, php va por su versión 7, así que en mi caso es php7.0-gd el que me ha resuelto el problema.

Así pues, los pasos a seguir son estos:

  1. Entra en la terminal de linux
  2. Escribe esto para actualizar el repositorio: sudo apt-get update
  3. Busca el módulo más reciente de tu php: sudo apt-search cache php*-gd
  4. Te mostrará los que existen, y tendrás que elegir el último. En mi caso es php7.0-gd
  5. Instala el módulo: sudo apt-get install php7.0-gd
  6. Resetea el servicio apache para que todo funcione inmediatamente: sudo service apache2 restart
  7. Listo, ya debe funcionarte el recorte de imágenes.

Yo con esto he solucionado el problema. ¿Y tú?

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *